Search

 
Login

Knowledgebase:
System Requirements
Posted by Jay Farr, Last modified by Jay Farr on 12 May 2014 11:23 AM

System Requirements:

Operating SurveySquare.com as a User:

Operating systems:  SurveySquare.com was designed to run on Windows Operating System.  We support Microsofts Internet Explorers version 9.0 and 10.0 plus current versions of Chrome and FireFox.

Taking our Surveys:

SurveySquare.com Surveys runs on the most popular web browsers available today and includes the following supported browser list:

Supported Browsers:

  • Microsoft Internet Explorer (IE) versions 9.0 and 10.0
  • FireFox Browser current version
  • Chrome current version

Cookie Settings:  Additionally, we require respondents to allow for Cookies in their browsers that help us to enhance our survey process.  We do not use any personal information with the use of cookies.  For more information on this see our Privacy Policy.

Please click here to learn how to allow for Cookies.
http://www.surveysquare.com/Response/TakeSurveyErrorMsgJSEnable.aspx

JavaScript Settings:  JavaScripts are also required to be Enabled when your respondents take our surveys.

Please click here to learn how to turn on JavaScripts. http://www.surveysquare.com/Response/TakeSurveyErrorMsgJSEnable.aspx


Comments (0)